Почему не работает запись в Паскале по задаче: Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.
Вот запись, исправьте пожалуйста:
program chisla;
var a,b,k:integer;
begin
k:=0;
writeln(Введите число);
readln(a);
repeat
if(a mod 2=0)and(a mod 4=0)then
k:=k+1
until a=0;
writeln(Количество чисел=,k)
end.

Var a,b,k:integer;
begin
k:=0;
writeln(Введите число);
readln(a);
repeat
if (a mod 10) in [4,8] then k:=k+1;
a:=a div 10;
until a=0;
writeln(Количество чисел=,k)
end.

Введите число
24583
Количество чисел=2


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку