Составьте программу которая заполняет массив s [1..15] случайными целыми числами в диапазоне от 1 до 15 и находит среднее арифметическое элементов с четными значениями и четными индексами

Если в паскале то вот
vara:array [1..30] of integer;i,s,k,n:integer;h:real;begins:=0;k:=0;writeln(введите количество чисел);read(n);randomize;for i:=1 to n do begina[i]:=random(100);write(a[i]:3);end;writeln();for i:=1 to n do beginif (a[i] mod 2=0) and (i mod 2=0) then begins:=s+a[i];k:=k+1;end;end;if k>1 then h:=s/k;writeln(h); if k=0 then begin writeln(таких чисел нет); read; halt; end;end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×