Дан одномерный массив. Найти функцию максимум+минимум. Последовательный переход с заданного по последний элемент. (Максимум) С первого по заданный пользователем (Минимум)
Написать программу на php/pascal
Помогите пожалуйста, люди добрые.

Var n,m:integer;b:boolean;
function fminmax(k:integer;d:boolean):integer;
var a:array[1..30] of integer;j,max,min:integer;
begin
for j:= 1 to 30 do begin a[j]:= random(100)-50; write(a[j]:4);end;
max:= -100;min:=100;
if b = true then 
for j:= 1 to k do begin
if max < a[j] then max := a[j];fminmax:=max;end
else
for j:= n to 30 do begin
if min > a[j] then min := a[j];
fminmax:=min;end;
end;
begin
write (Введите число < 25);Read(n);
write (Определять max(true -да, false- нет));Read(b);
m:= fminmax(n,b);
writeln;
if b = true then write(max = ,m)
else
write(min = ,m);end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку