Составьте программу которая заполняет массив а 1..20 случайными целыми числами в диапазоне от 1 до 10 и находит среднее арифметическое элементов с четным значением и нечетными индексами

Var
  a:array[1..20] of integer;
  i,n,c:integer;
   begin
    for i:=1 to 20 do
     begin
     a[i]:=random(10)+1;
     write(a[i], );
      if i mod 2 = 1 then
       if a[i] mod 2 = 0 then
       begin
        c:=c+a[i];
        n:=n+1;
      end;
    end;
    writeln;
        writeln( c/n);
    end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку