Написать программу, выделяющую из некоторого заданного множества подмножество четных чисел. Паскаль, как можно быстрее, пожалуйста.
Var a,b:set of integer;
i,n: integer;
begin
write(кол-во элементов множества: );
readln(n);
randomize;
for i:=1 to n do
a:=a+[random(250)];
write(элементы множества: );
foreach i in a do
begin
write(i, );
if i mod 2 = 0 then b:=b+[i];
end;
writeln;
write(подмножество четных элементов: );
foreach i in b do write(i, );
end.
Оцени ответ
