Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент. Протестировать программу на массивах размерностью 8 и 10 элементов.
Вот что получилось:
uses Crt;
const n = 10;
var A: array [1..n] of integer;
i, max: integer;
begin
ClrScr;
Randomize;
max:=-1*maxint;
WriteLn ( Massiv I: );
for i:=1 to n do
begin
A[i] := 1+random(10);
Write (A[i]:4);
if A[i]>max then max:=A[i] ;
end;
WriteLn; WriteLn; WriteLn ( Max = , max);
WriteLn; WriteLn ( Massiv II: );
for i:=1 to n do
begin
A[i]:=A[i]+max;
Write (A[i]:5);
end;
ReadLn;
end.
Оцени ответ
