Написать программу вычисления значений функции:
y=2x/(x+1) для всех х из интервала [-2;2] с шагом равным 1
Пожалуйста со схемкой и самой программой. Спасибо

Программа:
var x,y,h:real; 
begin
x:=-2;h:=1;
writeln( x     y);
while x<=2 do
 begin
 write(x:3);
 if x+1<>0 then
   begin
    y:=2*x/(x+1);
   writeln(y:7:2)
  end
   else writeln(  функция не определена);
 x:=x+h;
 end;
end.

Пример:
 x     y
 -2   4.00
 -1  функция не определена
  0   0.00
  1   1.00
  2   1.33

Блок-схема - в прилагаемом файле

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку