Необходимо написать программу на Паскале, которая будет удалять из строки все стоящие подряд одинаковые элементы, если их больше 2. Примеры: aabbbc -> aac;
aabbbac -> c;
Var s:string; c:char; i:integer;
begin
write(s = ); readln(s);
i:=1;
while (i+2<=length(s)) do
if(s[i]=s[i+1])and(s[i+1]=s[i+2])
then begin
c:=s[i];
while (i<=length(s))and(c=s[i]) do delete(s,i,1);
i:=1;
end
else i:=i+1;
writeln(s);
end.
Оцени ответ
