Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например 0, 1, 2 или a, b, c) в которой нет двух смежных идентичных подпоследовательностей. Для n=11 последовательность может иметь вид "01020120210".

#include
#include
#include
using namespace std;

void main()
 {
srand(time(NULL));
int n,k=0,k1=4;
cin >> n;
                         //вводишь количество символов
string *s=new string [n];

for (int i = 0;i < n;++i)
{
while (k == k1)
{
k = rand() % 3;
}
switch (k)

{
case 0:s[i] = 0;cout << s[i];break;
case 1:s[i] =1;cout << s[i];break;    //вместо 0,1,2 пишешь свой алфавит .
case 2:s[i] =2;cout << s[i];break;

}

k1 = k;

}

system("pause");
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку