Помогите написать программу,пожалуйста.
Подсчитать сумму ряда
-1-2+3+4-5-6+7+8.....+N
N-вводится пользователем
(цикл со счетчиком (FOR i:=1 to N do))

// PascalABC.NET 3.0, сборка 1138
var
  i,n,s:integer;
begin
  Write(n=); Read(n);
  s:=0;
  for i:=1 to n do
    if ((i mod 4)=1) or ((i mod 4)=2) then s:=s-i else s:=s+i;
  Writeln(Сумма ряда равна ,s)
end.

Тестовое решение:
n=13
Сумма ряда равна -1



Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку