Составьте программу для вычисления косинусов углов треугольника со сторонами a, b, c. Указание. Примените теорему косинусов: c2=a2 + b2 -2ab * cos α
Var a,b,c,cosa, cosb, cosc:real;
begin
writeln(Введите стороны треугольника АВС);
read(a,b,c);
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c);
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a);
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b);
writeln(Косинус угла А = , cosa, Косинус угла В =, cosb, Косинус угла C =, cosc);
end.
Оцени ответ
