Задача на тему Циклы с параметром
Помогите пожалуйста, а то вообще не понимаю эту тему:(
В некоторых языках программирования, в том числе и в Паскале, нет операции возведения в степень.
Составьте программу возведения некоторого целого числа X в степень Y, если числа X и Y вводятся с клавиатуры.
Почему же нет операции?
я знаю как минимум 2 способа
1) через формулу exp(ln(X) * Y)
2) функция pow(X, Y);
но если у вас тема про циклы, видимо вам надо вручную посчитать степень. тогда опишу вам внутренности функции pow
res:=x;
for i:=2 to y do
res:=res*x;
Вот полностью программа
Var res,x,i,y: integer;
Begin
writeln(Введите x);
readln(x);
writeln(Введите y);
readln(y);
res:=x;
for i:=2 to y do
res:=res*x;
writeln(res);
readln();
end.
Оцени ответ
