ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!
25баллов
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.
Входные данные
Задано единственное целое число N
Выходные данные
Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Примеры
входные данные
15
выходные данные
1
4
9

Var n,k:integer;
begin
write(n=); readln(n);
k:=1;
while k*k<=n do
 begin
 writeln(k*k);
 k:=k+1;
 end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку