Пользователь вводит положительное целое число , не превышающее 10^9, нужно написать программу , которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр , меньших 7, требуется на экран вывести 0
Program n1;
var n,k,s:real;
i:integer;
begin
readln(n);
if (n<1000000000) and (n>0) then
begin
writeln(число=,n);
if n>=6 then
begin
k:=0;
s:=0;
while k<7 do
begin
s:=s+k;
k:=k+1;
end;
writeln(сумма цифр=,s);
end else
writeln(0);
end;
end.
Оцени ответ
