Решить в паскале
№1
Составить программу вычисления значений функции F(x) на отрезке [a;b] с шагом h. Результат представить в виде таблицы, первый столбец которой – значение аргумента, второй – соответствующие значения функции: F(x)=2cosx-1
№2
Дан числовой ряд и малая величина ε. Найти сумму ряда с точностью ε, общий член задан формулой: an=2n-1/2^n
1)var
a,b,h:real;
begin
readln(a);
readln(b);
readln(h);
while a begin
writeln(a, ,2*cos(a)-1:8);
a+=h;
end
end.
2)var
eps,sum,current,n:real;
begin
readln(eps);
sum:=0;
n:=0;
repeat
current:=2*n-1/power(2,n);
n+=1;
sum+=current;
until current>eps;
writeln(sum);
end.
Оцени ответ
