Составить программу для вычисления
A - сумма отрицательных элементов массива;
B – количество четных элементов массива;
C - номер первого положительного элемента массива.
Полученные значения элементов А,B,C,F вывести на печать.
F:=C+((A+B)/(10-C+A)).
Const n=20;
var x,y : array[1..n] of integer;
i,a,b,c : integer; f:real;
begin
Randomize;
writeln(Исходный массив:);
for i:=1 to n do
begin
x[i]:=random(101)-50;
write(x[i], );
end;
writeln;
a:=0; b:=0; c:=0;
for i:=1 to n do
begin
if x[i]<0 then a:=a+x[i];
if x[i] mod 2 = 0 then b:=b+1;
if (c=0)and(x[i]>0) then c:=i;
end;
writeln(A=,a, B=,b, C=,c);
f:=c+((a+b)/(10-c+a));
writeln(F=,f:5:2);
end.
Пример:
Исходный массив:
10 -37 1 31 -22 45 3 32 -2 48 -19 -48 39 22 -39 -29 -49 8 -16 22
A=-261 B=10 C=1
F= 2.00
Оцени ответ
