Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 7 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности,а затем сами числа. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 4.

Var a:array[1..1000] of integer; 
sum,n,i:integer; 
begin 
sum:=0; 
writeln(Введите количество чисел); 
read(n); 
writeln(Введите числа); 
for i:=1 to n do begin 
read(a[i]); 
if (a[i] mod 7=0) and (a[i] mod 10=4)then sum:=sum+a[i]; 
end; 
writeln(Сумма элементов кратных 7 и оканчиваюшихся на 4 = ,sum); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку