Написать программу с использованием цикла while. Через каждые пять секунд каждая амеба делиться на две амебы. Изначально была 1 амеба. Сколько амеб будет через N секунд? Проверить решение для 10, 25, 72 секунд.

Это просто! Вот решение:

Var n,a,time:integer;
Begin
Readln(n);
a:=1;time:=0;
while time
if frac(time/5)=0 then a:=a*2;
time:=time+1;            //èëè âìåñòî ýòîãî " Inc(time); "
End;
Writeln(a);
End.


И результаты проверки:
10 секунд: 4 амёбы
25 секунд: 32 амёбы
72 секунды: 32768 амёбы


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку