1) Написать программу, которая определяет номера строк двумерного массива A[1..6,1..4], в которых содержится хотя бы один нулевой элемент. 2) 5. Составить программу заполнения массива B[1..10] таким образом: элементы с нечетными индексами равны числу 2, а элементы с четными индексами равны числу 5.
1)
var A: array [1..6,1..4] of integer;
i,j: integer;
begin
randomize;
for i := 1 to 6 do begin
for j := 1 to 4 do begin
A[i,j] := random(20) - 10;
end;
end;
for i := 1 to 6 do begin
for j := 1 to 4 do begin
if (A[i,j] == 0) then begin
writeln("0 v stroke ", i);
continue;
end;
end;
end;
end.
2)
var B: array [1..10] of integer;
i: integer;
begin
for i := 1 to 10 do begin
if (i mod 2 == 0) then B[i] := 5;
else B[i] := 2;
end;
for i := 1 to 10 do begin
writeln(B[i]);
end;
end.
Оцени ответ
