Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у Пятачка и Кролика он съел по 100 г меда. Определите, сколько килограммов меда он съест на десятом дне рождения.

Числа Фибоначчи (вместо 1 только 100)!
var m1,m2,s,i:integer;
begin
m1:=100; m2:=100;
for i:=3 to 10 do
 begin
 s:=m1+m2;
 m1:=m2;
 m2:=s;
 end;
writeln(s);
end.

Результат:
5500

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку