Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. Через сколько минут температура воды станет ниже Nо С?

Var A, gradus, minut, N: real;
Begin
Writeln(Введите A градусов);
readln(A);
Writeln(До какой температуры остужать:);
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
   A:=A*(1-0.15);
    gradus:=gradus-A;
    minut:=minut+1;
 end;

Writeln(Кипяток остынет до ,N, градусов через , minut, минут);
readln();
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку