Безумно нужна помощь .......напишите программу ,которая формирует массив из 20 случайных чисел в диапазоне от 0 до 10 Найдите самый частно встречающийся элемент и посчитайте сколько р
аз он повторяется в массиве....
Const n=20; m=10;
var
a:array[1..n] of integer;
k:array[0..m-1] of integer;
i,j,max:integer;
begin
writeln(Исходный массив:);
for i:=1 to n do
begin
a[i]:=random(m);
write(a[i], );
end;
writeln;
for j:=0 to m-1 do k[j]:=0;
for i:=1 to n do k[a[i]]:=k[a[i]]+1;
max:=0;
for j:=1 to m-1 do
if k[j]>k[max] then max:=j;
writeln(Самый часто встречающийся элемент: ,max);
writeln(Встречается в массиве ,k[max], раз(а));
end.
Пример:
Исходный массив:
1 1 8 8 6 2 3 8 8 9 5 2 6 9 8 7 3 9 7 9
Самый часто встречающийся элемент: 8
Встречается в массиве 5 раз(а)
Оцени ответ
