Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом. На вход программе подается строка, состоящая не более чем из 255 символов. Выведите искомое число. паскаль

Var s : String;

Function isPali(ss : String) : Boolean;
Begin
  If Length(ss)>0 then isPali:=(ss[1]=ss[Length(ss)]) and isPali(Copy(ss,2,Length(ss)-2))
  else isPali:=True;
end;

Function NtoPali(ss : String) : Integer;
Begin
  If isPali(ss) then NtoPali:=0 else NtoPali:=1+NtoPali(Copy(ss,2,Length(ss)-1));
end;

Begin
  s:=abcdc;  // Readln(s);
  Writeln(NtoPali(s));
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку