Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при этом прежним порядок остальных цифр. Пример 5101234-50234

#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
#include
typedef unsigned long long ulol;
typedef long long lol;
typedef long int  li;
#define mp          make_pair
#define F           first
#define S           second
#define sqr(a)      ( (a) * (a) )
#define pb          push_back
#define INF         999999999
#define ret(a)      cout << endl; system("pause"); return(a)
//#define ret(a)      return(a)
using namespace std;int main()
{
    string s, ans;
    cin >> s;
    for(int i = 0 ; i < s.size() ; i ++)
        if( s[i] != 1 )
            ans.pb( s[i] );
    cout << ans;
    ret(0);
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку