Шестизначный
билет для проезда в любом транспортном средстве называется «счастливым
по-ленинградски» , если сумма первых трёх его цифр равна сумме трёх последних
его цифр. Определить, является ли билет с введённым с клавиатуры номером
«счастливым по-ленинградски» .
Исходные
данные: в первой строке вводится номер
билета (6 цифр) .
Результат
работы программы: во второй строке вывести
на экран текст «Билет счастливый» , либо «Билет не является счастливым». помогите написать программу, я ее примерно написала, но не работает.
Вариант 1
var s: string;
begin
read(s);
if ord(s[1]) + ord(s[2]) + ord(s[3]) = ord(s[4]) + ord(s[5]) + ord(s[6])
then writeln(Билет счастливый)
else writeln(Билет не является счастливым);
end.
Вариант 2
var n: integer;
begin
read(n);
if n div 100000 + n div 10000 mod 10 + n div 1000 mod 10 = n div 100 mod 10 + n div 10 mod 10 + n mod 10
then writeln(Билет счастливый)
else writeln(Билет не является счастливым);
end.
Оцени ответ
