Найти среднее арифметическое элементов одномерного массива А10. Составить программу.

Допустим, что все элементы должны быть положительными.

 

#include
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int a[10] = { 5, 2, 8, 21, 17, 9, 0, 3, 1, 2 };
   float mean = 0;

   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ;

      mean += a[i]; //Найти сумму всех элементов
   }

   mean /= 10;

   cout << "nArithmetic mean = " << mean << endl;

   return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку