Напишите программу, которая находит произведение двух наибольших чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Значения чисел не превышают 30000. Программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наибольшие

var temp,max,max2:integer;

begin

   readln(temp);

   max:=0;

   max2:=0;

   while (temp<>0) do begin

      if(temp>max) then begin max2:=max; max:=temp; end

         else if(temp>max2) then max2:=temp;

      readln(temp);

   end;

   writeln(max*max2)

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку