Помогите, пожалуйста, написать программу(паскаль). С пояснениями, желательно.

Нужно с for.

Найти сумму всех n-значных чисел, кратных k.(1 <(или равно) n<(или равно)4).

program sada;

var k,n,res,i:integer;

     temp:string;

begin

res:=0;

readln(k);

temp:=;

for i:=1 to n do

temp:=temp+9;

n:=strtoint(temp);

for i:=1 to n do begin

if (i mod k = 0) then res:=res+i;

end;

writeln(res);

end.

 

 

p.s. Программа написана на pascalABC

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку