составить программу вычеслений степени числа А с натуральным показателем N.

Тут используется собственная функция для нахождения степени числа.

 

#include
using std::cout;
using std::cin;
using std::endl;

int powerFunction(int, int);

int main()
{
   int number, power;

   cout << "Enter A: ";
   cin >> number;
   cout << "Enter N: ";
   cin >> power;

   cout << number << " to the power of " << power
      << " = " << powerFunction(number, power) << endl;

   return 0;
}

int powerFunction(int n, int p)
{
   int temp = 1;

   for(int i = 0; i < p; i++)
   {
      temp *= n;
   }

   return temp;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку