Одноклеточная амеба каждые три часа делится на 2 клетки составьте алгоритм вычисления времени через которое будех X амеб
Program pr;
uses crt;
Var vremya, X, kol_vo:integer;
Begin
kol_vo:=1; {первоначально будет 1 амеба}
vremya:=0;
Write(Введите необходимое кол-во амеб: );
readln(X);
While (kol_vo < X) do
Begin
kol_vo:=kol_vo*2;
vremya:=vremya+3;
end;
Writeln(Время = ,vremya, часа);
readln();
end.
Оцени ответ
