Три точки заданы своими координатами. Определите, можно ли построить треугольник с вершинами в этих точках. Составьте программу в Pascal, пожалуйста!
//Pascal ABC.NET v3.0 сборка 1111
Var
x1,y1,x2,y2,x3,y3:integer;
a1,a2,a3:real;
begin
read(x1,y1,x2,y2,x3,y3);
a1:=sqrt(sqr(x1)+sqr(y1));
a2:=sqrt(sqr(x2)+sqr(y2));
a3:=sqrt(sqr(x3)+sqr(y3));
if (a1<(a2+a3)) and (a2<(a1+a3)) and (a3<(a2+a1)) then writeln(Yes) else writeln(No);
end.
Пример ввода:
1
2
3
4
5
6
Пример вывода:
No
Оцени ответ
