В массиве хранится информация о среднесуточной температуре за текущую неделю. Составить программу, определяющую среднюю температуру за неделю и количество дней, в течение которых температура была выше средней
Var
a: array[1..7] of integer;
i, k: integer;
s: real;
begin
for i:=1 to 7 do
begin
write(Введите погоду для , i, дня недели: );
readln(a[i]);
s:=s+a[i]
end;
s := s/7; k:=0;
for i:=1 to 7 do
if a[i] > s then inc(k);
writeln(Средняя температура: , s);
writeln(Кол-во дней: , k);
end.
Оцени ответ
