Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Var
a: array[1..10000] of integer;
i, k, n: integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
writeln;
k:=0;
for i:=2 to n do
if a[i] > a[i-1] then
inc(k);
writeln(k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку