Помогите решить пожалуйста
По данному натуральному числу N найдите сумму чисел 1+1/1!+1/2!+1/3!+...+1/N!. Количество действий должно быть пропорционально N.
Входные данные
Задано единственное число N
Выходные данные
Необходимо вывести результат вычисления в виде действительного числа c точностью до 5 знаков после запятой.
Примеры
Входные данные
1
Выходные данные
2
Var i,n: integer;
s,t: real;
begin
write(n = ); readln(n);
s:=1; t:=1; i:=1;
repeat
t:=t/i;
s:=s+t;
i:=i+1;
until i>n;
writeln(сумма ряда: ,s:7:5);
end.
Оцени ответ
