Дано число. определить чему равна сумма нечетных цифр в этом числе
Var
a,s: integer;
begin
readln(a);
s := 0;
while a >0 do
begin
if a mod 10 mod 2 <> 0 then
inc(s, a mod 10);
a := a div 10;
end;
writeln(s);
end.
Оцени ответ
Вход
Регистрация
Задать вопрос
Var
a,s: integer;
begin
readln(a);
s := 0;
while a >0 do
begin
if a mod 10 mod 2 <> 0 then
inc(s, a mod 10);
a := a div 10;
end;
writeln(s);
end.