Помогите написать программу на Паскале
Дана строка символов.определить длину самого длинного слова и напечатать его.
Желательно написать программу с помощью функции Pos
Var
Text, Slovo, max:string;
Begin
WriteLn(Введите строку, разделенную пробелами: ); ReadLn(Tex);
Text:= Text + ;
max:=;
While Pos( ,Text) <> 0 do
Begin
Slovo:= Copy(Text, 1, Pos( ,Text) - 1);
Delete(Text, 1, Pos( ,Text));
if Length(Slovo) > Length(max)
then max:= Slovo;
End;
WriteLn(Самое длинное слово: " ,max, " его длина ,Length(max));
ReadLn;
End.
Оцени ответ
