Написать программу нахождения суммы нечётных цифр в натуральном числе. Pascal

// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var n:=ReadInteger(n=);
  var s:=0;
  while n<>0 do begin
    var d:=n mod 10;
    if Odd(d) then s+=d;
    n:=n div 10
    end;
  Writeln(Сумма нечетных равна ,s)
end.

Тестовое решение:
n= 25325423
Сумма нечетных равна 16

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку