Дано трехзначное число. Напишите программу, которая определяет: есть ли среди цифр заданного целого трехзначного числа одинаковые.
Пример входных данных и выходных данных:
123 - Нет
121 - Да
222 - Да
В программе использовать div и mod
помогите пожалуйста
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
var
n,d1,d2,d3:integer;
begin
Write(n=); Read(n);
d1:=n div 100; d3:= n mod 10;
d2:=(n div 10) mod 10;
if (d1=d2) or (d1=d3) or (d2=d3) then Writeln(Да)
else Writeln(Нет)
end.
Тестовые решения:
n=123
Нет
n=121
Да
n=222
Да
Оцени ответ
