Pascal.ABC
Дано случайное количество чисел, узнать сколько совершенных чисел в этом ряду (написать программу).
Var i, k, n, a, sum, kol: Integer;
Begin
readln(n);
kol := 0;
for k := 1 to n do begin
sum := 0;
read(a);
for i := 1 to a-1 do
if a mod i = 0 then sum := sum + i;
if sum = a then kol := kol + 1;
end;
writeln(kol);
End.
Оцени ответ
