Составьте программу заполнения массива из ста чисел, со случайными значениями из диапазона от -20 до 20. Посчитайте в этом массиве количество положительный и отрицательных чисел.
Const n=100;
var x : array[1..n] of integer;
i,k1,k2 : integer;
begin
Randomize;
writeln(Исходный массив:);
for i:=1 to n do
begin
x[i]:=random(41)-20;
write(x[i], );
end;
writeln;
for i:=1 to n do
begin
if x[i]<0 then k1:=k1+1;
if x[i]>0 then k2:=k2+1;
end;
writeln(k1=,k1, k2=,k2);
end.
Оцени ответ
