Дано число а. Если а >0 на единицу, иначе уменьшить на 1. Проверить алгоритм для а:=3; а:=0; а:=-12
Var
a: integer;
begin
readln(a);
if a > 0 then
inc(a)
else
dec(a);
writeln(a);
end.
Входные данные: 3
Выходные данные: 4
Входные данные: 0
Выходные данные: -1
Входные данные: -12
Выходные данные: -13
P.S. Процедура inc(a) увеличивает a на 1, процедура dec(a) уменьшает a на 1.
Оцени ответ
