Получив на вход число X этот алгоритм печатает два числа a и b Укажите наименьшее из таких чисел X при вводе которых алгоритм печатает сначала 3 а потом 18
var x,a,b: integer
begin
readln(x);
a:=0, b:=0
while x>0 do
begin
a:=a+1
if x mod 2=0 then
b:=b+x mod 10
x:=x div 10
end;
writeln(a);
writeln (b);
end.
Переменная а ведёт подсчёт количества цифр в числе, значит, число трёхзначное. Переменная b пополняется последней цифрой числа только тогда, когда число чётно. Затем производится сокращение числа на последнюю цифру. Так как мы ищем наименьшее число, то им будет являться число 288.
Оцени ответ
