Составить программу которая считает колличество нулевых элементов массива B

Вот пример реализации на языке паскаль:

program nullarray;
const
max = 100;

var
arr : array[1..max] of integer;
i, num, summ : integer;

begin
{ заполняем массив случайными числами }
randomize;
for i:=1 to max do arr[i]:=random(10);

{ ищем нулевые элементы и считаем их }
summ:=0;
for i:=1 to max do begin
num:=arr[i];
if num=0 then summ:=summ+1;
end;
writeln(summ);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку