Составить программу для нахождения произведение чисел от 1 до n.
Для циклов:
1)for
2)while
3)until

//Pascal
var
  a, p:  word;
  i, n: integer;

begin
  readln(n);
  //цикл for
  p := 1;
  for i := 1 to n do
    p := p * i;
  writeln(p);
 
  //цикл while
  i := 1;
  p := 1;
  while i <= n do
  begin
    p := p * i;
    i := i + 1;
  end;
  writeln(p);
 
  //цикл repeat
  i := 1;
  p := 1;
  repeat
    p := p * i;
    i := i + 1;
  until i > n;
  writeln(p);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку