Напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ с конца строки до тех пор, пока в строке не останется 1 символ.
Входные данные: ввести строку с длиной не более 255 символов.
Выходные данные: вывести строку, сокращая каждый раз на 1 символ (в начале вывести всю строку, последней строкой должна быть строка из одного символа) с конца строки до тех пор, пока в строке не останется 1 символ.
В паскаль. И если не трудно с объяснением. Заранее огромнейшее спасибо!

Я не знаю, что тут нужно пояснять. первый оператор вводит строку, второй выводит в цикле...

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var s:=ReadlnString(Исходная строка:);
  for var i:=s.Length downto 1 do Writeln(Copy(s,1,i))
end.

Тестовое решение:
Исходная строка: Дронопотам
Дронопотам
Дронопота
Дронопот
Дронопо
Дроноп
Дроно
Дрон
Дро
Др
Д

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку