1. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a < 5 then
a := 5;
2. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a > 5 then
a := 12;
3. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a < 5 then
a := a + 12
else
a := a - 7;
4. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a < 15 then
a := a + 12
else
a := a - 7;
5. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a < 5 then a := a + 12
else a := a - 7;
if a < 5 then a := a + 12
else a := a - 7;
6. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10;
if a > 5 then a := a + 12
else a := a - 7;
if a > 5 then a := a + 12
else a := a - 7;
7. Определите значение переменной «a» после выполнения фрагмента программы:
a := 10; b := 3;
if a > b then b := b + 12
else a := a - 7;
if a > b then a := a + 12
else a := a - 7;
Часть 2
1. Дано целое число. Определить является ли оно четным.
2. Даны два числа. Замените меньшее из двух чисел их суммой, а большее
произведением этих чисел.
3. Дано двузначное число. Определите, входит ли в него цифра 6.
1. 10
2. 12
3. 3
4. 22
5. 15
6. 34
7. 3
Часть 2
1.
Var
n:integer;
Begin
Write(Введи число );
Readln(n);
if (n mod 2) = 0 then write(n, чётное) else write(n, нечётное);
End.
2.
Var
a,b:integer;
Begin
Write(Введи числа );
Readln(a,b);
if a>b then Begin Write(a = ,b*a, b = ,a+b) else write(a = ,a+b, b = ,a*b);
End.
3.
Var
n:integer;
Begin
write(Введи двузначное число );
Readln(n);
if ((n div 10) = 6) or ((n mod 10) = 6) then write(6 присутствует) else write(6 нет в этом числе);
End.
Оцени ответ
