ПОМОГИТЕ С ИКТ!!! ПАСКАЛЬ! ДАЮ 23 балла!
_____________________________
Задача: Вводится последовательность чисел, которая оканчивается 0. Определите количество и сумму чисел, которые кратны B. Если таких чисел нет, то сообщить об этом. (решить нужно с помощью цикла while)
//Pascal
//вариант с циклом while
var
a,b, n: integer;
begin
n:=0;
readln(b);
readln(a);
while a<>0 do begin
if a mod b = 0 then n:=n+1;
readln(a);
end;
writeln(n);
end.
Оцени ответ
