Напишите программу которая в последовательности натуральных чисел находит среднее арифметическое трехзначных чисел или сообщает что таких чисел нет.

// PascalABC.NET 3.1, сборка 1179 от 29.02.2016
begin
  var a:=ArrRandom(ReadInteger(n=),1,150);
  a.Println;
  var s:=a.Where(x->x in [100..999]);
  if s.Count>0 then Writeln(Ср.арифм. трехзначных ,a.Average)
  else Writeln(Нет трехзначных чисел)
end.

Тестовое решение:
n= 10
143 67 131 52 39 135 42 83 105 142
Ср.арифм. трехзначных 93.9

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку