Написать программу, вычисляющую значение функции:
y = cosx+cos2x+cos3x+…+cos30x

//Pascal ABC.NET v3.1 сборка 1172

Var
 y,x:real;
 i:integer;
begin
 readln(x);
 for i:=1 to 30 do
 y:=y+cos(x*i);
 writeln(y);
end.

Пример ввода:
1
Пример вывода:
-1.32716415333901

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку