Номер билета в трамвае состоит из 6 цифр. Счастливым называется билет, сумма первых трех цифр в котором равна сумме последних трех.
Сколько существует счастливых билетов таких, что они состоят только из цифр от 0 до 5 (при этом могут использоваться не все цифры)?
Число билетов: 4331
var i,j,k,nmb: integer;
a: array[1..15] of integer;
begin
for i:=0 to 5 do
for j:=0 to 5 do
for k:=0 to 5 do
if i+j+k>0 then inc(a[i+j+k]);
{ подсчет числа билетов}
nmb:=0;
for i:=1 to 15 do
nmb:=nmb+a[i]*a[i];
writeln(число билетов: ,nmb);
end.
Оцени ответ
